Utilisation du mode commande sous TeXnicCenter

Utilisation de code texgraph dans LateX avec l'environnement \\begin{texgraph}...\\end{texgraph} et le paquet texgraph.sty.

Utilisation du mode commande sous TeXnicCenter

Messagepar Lise7413 » 11 Juil 2011 21:39

Bonsoir,

J'écris mon mémoire sous LaTex (ma distribution est MikTex 2.9 et l'éditeur TeXnicCenter) et j'aimerais construire des figures via la commande texgraph.
Le souci étant que je suis novice, même en ce qui concerne le langage Tex. J'aurais juste besoin d'une traduction des instructions suivantes:

" L'archive contient également une version sans interface graphique permettant d'utiliser du code texgraph
directement dans un document LaTeX par le biais du package texgraph.sty qui est dans l'archive.
Pour cela il vous faut:

-> ajouter le chemin d'accès au dossier TeXgraph1.95\TeXgraph à la variable PATH (?)

-> créer la variable d'environnement TeXgraphDir contenant le chemin d'accès au
dossier TeXgraph1.94\TeXgraph, (?) "


Je ne sais pas ce que signifie la variable PATH et la variable d'environnement. Je suis vraiment une novice.

Si quelqu'un parmi vous pourrait m'expliquer comment le faire sous TexnicCenter, ce serait très sympathique.

Sinon, pour le reste (copier le fichier .sty) je pense avoir compris.

Merci d'avance
Lise7413
 
Messages: 4
Inscription: 11 Juil 2011 17:53

Re: Utilisation du mode commande sous TeXnicCenter

Messagepar P.Fradin » 11 Juil 2011 22:13

Bonsoir Lise,
Et bienvenue sur le forum TeXgraph!
La variable d'environnement PATH n'a rien à voir avec TeX ni TeXnicCenter, c'est une variable de Windows! C'est elle qui contient les chemins où windows peut chercher les programmes appelés par l'utilisateur.
Pour modifier la variable PATH, je suppose que tu as pris la dernière version stable TeXgraph1.95 et qu'elle est installée dans c:\TeXgraph1.95 (surtout pas de dossiers contenant des espaces ou autres caractères exotiques!), allons-y:

Démarrer -> Panneau de configuration -> Système -> Onglet Avancé -> bouton Variables d'environnement
dans Variables système Sélectionner PATH puis le bouton Modifier, mettre le curseur à la fin de la Valeur de PATH et ajouter:
;c:\TeXgraph1.95\TeXgraph

PS: ne pas oublier le point-virgule (séparateur), ne pas ajouter d'espaces, puis on valide tout ça avec les boutons OK.

Maintenant pour ajouter la variable d'environnement TeXgraphDir:
Démarrer -> Panneau de configuration -> Système -> Onglet Avancé -> bouton Variables d'environnement
dans Variables système cliquer le bouton Nouveau, il faut alors entrer le nom (TeXgraphDir) et la valeur (c:\TeXgraph1.95\TeXgraph), il ne reste plus qu'à valider tout ça.
P.Fradin
Avatar de l’utilisateur
P.Fradin
Administrateur du site
 
Messages: 1835
Inscription: 29 Oct 2008 15:04

Re: Utilisation du mode commande sous TeXnicCenter

Messagepar Lise7413 » 12 Juil 2011 10:01

Merci.

Je vais essayer maintenant.
Lise7413
 
Messages: 4
Inscription: 11 Juil 2011 17:53

Re: Utilisation du mode commande sous TeXnicCenter

Messagepar Lise7413 » 12 Juil 2011 16:02

Bonjour,

Mon essai a échoué.

J'ai voulu compiler votre exemple proposé dans la rubrique Macros Tex. Mais la compilation a échoué. Voici un bout de mon .log:

"ABD: EveryShipout initializing macros
runsystem( CmdTeXgraph pdf essai)...disabled (restricted).
LaTeX Warning: File `essai.pdf' not found on input line 12.
! LaTeX Error: File `essai.pdf' not found.
"

J'ai certainement manqué des étapes. Que dois-je faire?
En plus je ne sais pas où le fichier 'essai.pdf' se trouve.


Merci.
Lise7413
 
Messages: 4
Inscription: 11 Juil 2011 17:53

Re: Utilisation du mode commande sous TeXnicCenter

Messagepar P.Fradin » 12 Juil 2011 22:00

Pour l'instant l'erreur n'a rien à voir avec le premier message. TeX est sympa, il dit qu'elle est l'erreur:
runsystem( CmdTeXgraph pdf essai)...disabled (restricted).

TeX n'a pas pu exécuter la commande car par défaut TeX n'a pas le droit de lancer d'autres programmes. Comme toujours la réponse est dans l'aide, c'est le point Important :D . A toi maintenant de chercher dans la configuration de ton éditeur où sont les commandes de compilation (latex et pdflatex) afin d'ajouter à la main l'option --shell-escape (il me semble que c'est ça pour MikTeX).

PS: je déplace le sujet dans le bon forum.
P.Fradin
Avatar de l’utilisateur
P.Fradin
Administrateur du site
 
Messages: 1835
Inscription: 29 Oct 2008 15:04

Re: Utilisation du mode commande sous TeXnicCenter

Messagepar Lise7413 » 13 Juil 2011 00:46

J'avais bien lu le paragraphe sur l'installation et avais ajouté l'option "--shell-escape" à "Command line arguments to pass to the compiler".
J'ai dû manquer une autre consigne. Je vais regarder de plus près la rubrique d'aide.

Merci bien.
Lise7413
 
Messages: 4
Inscription: 11 Juil 2011 17:53

Re: Utilisation du mode commande sous TeXnicCenter

Messagepar P.Fradin » 13 Juil 2011 09:55

Lise7413 a écrit:J'avais bien lu le paragraphe sur l'installation et avais ajouté l'option "--shell-escape" à "Command line arguments to pass to the compiler".

Manifestement l'éditeur n'a pas passé l'option dans la ligne de commande sinon, dans le log, on verrait quelque chose comme:
runsystem( CmdTeXgraph pdf essai)...executed.
P.Fradin
Avatar de l’utilisateur
P.Fradin
Administrateur du site
 
Messages: 1835
Inscription: 29 Oct 2008 15:04


Revenir vers TeXgraph dans LaTeX

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité

cron