Page 1 sur 1

balise, triangulation

MessagePublié: 25 Mai 2010 11:26
par homer3018
Bonjour bonjour :)

ça fait un moment que j'ai pas trainé ici ...

je reviens donc pour un petit dessin pas très compliqué :

Image

ce dessin est presque bien, à part le repère x,y (inutil ici) et les dexu cadres noirs, je préfèrerai des flèches, enfin quelque chose de plus sobre....

Merci du coup de main :)

edit : en fait si j'ai besoin ici du repère en x et y.... mais là en plein milieu, ... bon enfin au pire c'est pas grave :)

Re: balise, triangulation

MessagePublié: 25 Mai 2010 14:34
par P.Fradin
Bonjour homer3018!

Je te propose ce code:

Code: Tout sélectionner
[
view(-4,7,-5,5), Marges(0,0,0,0), size(10),
O:=-3.5*i, f:=1, dx:=5.5, dy:=2, E:=4, h:=0.75, alpha:=20*deg,
B:=O+dy+i*dx, D:=B+E*exp(i*alpha), G:=B-E*exp(i*alpha), C:=B-h*i*exp(i*alpha),
d:= [O,D] Inter [O-f*i, O-f*i+1], c:= [O,C] Inter [O-f*i, O-f*i+1],
g:= [O,G] Inter [O-f*i, O-f*i+1], u:=O-f*i-dy, v:=O-f*i+dy,

Arrows:=1, Width:=6, Ligne([O,i*Im(O)+Xmin,jump,Re(O)+i*Ymin,Re(O)+i*Ymax],0), Arrows:=0,
Width:=8, LineStyle:=dotted,
Droite(u,v), Droite(O+dx*i,O+dx*i+1),
Ligne([G-0.15,G+1.15,jump, C+0.15*exp(i*alpha), C-exp(i*alpha), jump,
       B,B+1.15*i, jump, D, D+1.15*i, jump, u,u+i/2,jump,v,v+i/2],0),
Width:=18, LineStyle:=solid, Ligne([G,D, jump,C,B,jump,u,v],0),
Width:=4, LineStyle:=dashed, Ligne([d,D,jump,g,G,jump,c,C],0),
LineStyle:=solid,
DotStyle:=dotcircle, FillColor:=red, DotScale:=2, Point(G,C,D),
FillColor:=white, DotScale:=1.5, Point(B,O,d,c,g),

LabelSeg( O-3,O+i*dx-3, "$dx$", [rotation:=0, Arrows:=2]),
LabelSeg(O-i*f-2.5, O-2.5, "$f$", [rotation:=0, Arrows:=2]),
LabelSeg(O+i*(dx+1), B+i, "$dy$", [rotation:=0, Arrows:=2]),
LabelSeg(B+i,D+i, "$e$", [rotation:=0, Arrows:=2]),
LabelSeg(C-0.5*exp(i*alpha),B-0.5*exp(i*alpha), "$h$", [rotation:=0, Arrows:=2]),
LabelArc(G+1,G,G+exp(i*alpha),1,1,"$\alpha$", [Arrows:=1]),

LabelDot(Re(O)+i*Ymax, "$x$", "SE"), LabelDot(i*Im(O)+Xmin, "$y$", "NE"),
Color:=blue,
LabelDot(G, "$G$", "N"), LabelDot(B, "$B$", "NO"),LabelDot(D, "$D$", "NE"),
LabelDot(C, "$C$", "SE"), LabelDot(O, "$O$", "E"),
LabelStyle:=bottom,
Label(d-0.35*i, "$d$"), Label(c-0.35*i, "$c$"), Label(g-0.35*i, "$g$"),
Color:=gray,
LabelDot(u+0.35*i, "$0$", "N"), LabelDot(v+0.35*i, "$2048$", "N"),

Color:=black, LabelSize:=footnotesize,
a:=4.7, b:=4.7+2.8*i, Arrows:=1, Width:=8, Ligne([a,b],0), Width:=4,
LabelStyle:=framed, FillStyle:=full, FillColor:=white,
Label(a, "Cible infrarouge"),

a:=4.7+i*Im(v), b:=v+0.25, Arrows:=1, Width:=8, Ligne([a,b],0), Width:=4,
LabelStyle:=framed+stacked, FillStyle:=full, FillColor:=white,
Label(a, "Pixels effectifs de la \\barette CCD")
]


CibleInfrarouge.png
CibleInfrarouge.png (19.86 Kio) Consulté 8260 fois

Re: balise, triangulation

MessagePublié: 25 Mai 2010 15:02
par homer3018
parfait, comme d'habitude, et rapide avec ça :)

edit : bon par contre, comme d'habitude des problèmes d'aperçu, adobe me fait une erreur, et dans le répertoire texgraph, je ne vois pas le pgf qu'on ait censé voir en aperçu...

j'avais deja eut le problème mais je sais plus ce que j'avais fait !

Re: balise, triangulation

MessagePublié: 26 Mai 2010 09:59
par homer3018
une idée ?

Re: balise, triangulation

MessagePublié: 26 Mai 2010 12:48
par P.Fradin
Tout est dit dans l'aide et le fichier Lisezmoi.txt.

Re: balise, triangulation

MessagePublié: 26 Mai 2010 14:19
par homer3018
lisezmoi contient des info concernant l'installation,

et dans l'aide " l'aperçu se fait en pressant la petite icône en forme d'oeil"...

j'ai changé le chemin d'accès a acrobat dans le fichier configuration, mais quand je clique sur aperçu, aucun file.pgf n'est créé, et si je le créé manuellement (export en pgf, puis renommage en file.pgf) et que je redemande l'aperçu, il me dit toujours fichier introuvable.........

par contre si j'ouvre apercu.tex (toujours à la suite de ces opérations) et que je le compile manuellement, ben là c'est bon, puisque j'ai créé le file.pgf...

je sais que j'ai deja eut ce soucis, mais je sais plus comment je l'avais réglé, mais bon au pire, c'est pas bien grave...

merci du code en tout cas .

Re: balise, triangulation

MessagePublié: 26 Mai 2010 14:32
par P.Fradin
Le soucis est que l'installation n'est pas "propre", ou que texgraph est dans un dossier dont le nom contient des caractères normalement à éviter, comme des espaces ou des accents ou ...

Re: balise, triangulation

MessagePublié: 26 Mai 2010 14:48
par homer3018
exact, j'avais pas vu les espaces qui se cachaient...

Merci, :)